Discussion - micro-ROS Button Tutorial

This is the discussion topic for the video linked above. Please keep all replies relevant to the content, otherwise create a new topic.


if i am use ESP32 Does micro-ROS good with ESP-SDK ?

Yes I have used micro-ROS with ESP-IDF on an ESP32-S3 and it worked great! The setup process is a little different to this video but the final code works basically the same.

Hi Josh,

thank you for your great tutorials.

You mention the option to get debug statements and ros running at the same time.
I assume you’d utilize stdio_filter_driver(&stdio_uart)
@DrJonEA (also youtube) is explaining and using this but it reliably crashes here.

Do you plan to dwell into a more detailed tutorial on this? maybe employing freertos?

Thanks and regards,

Hi All,
Josh, Thanks for your tutorials, love them.
I hit a road block @6:54/34:51 using “docker run -it --rm -v /dev:/dev/ --privileged --net=host microros/micro-ros-agent:humble serial --dev /dev/ttyACM0 -b 115200” command.
Ubuntu 22.04 can’t find the serial port /dev/ttyACM0. And ls /dev/ttyMC* also return “no Such file…”
I can see the system detects the Pico W board when I plug it in with the USB RPI-RP2 icon and I can also see it in the system log: sudo dmesg | grep ttyAC* =>" cdc_acm 1-1.2:1.0: ttyACM0: USB ACM device"
I have tried re-plugging in the “Pico w” board many times, but it never appears in the /dev as ttyACM* or ttyUSB*

sudo ./picotool info =>
Program information
name: pico_micro_ros_example
features: USB stdin / stdout

So it is in BOOTSEL mode.

Wow, just made it work. Just replugged the board board again (without pushing the BOOTSEL button) and the “docker run -it --rm -v /dev:/dev/ --privileged --net=host microros/micro-ros-agent:humble serial --dev /dev/ttyACM0 -b 115200” command worked :0

You are right it can take some attempts before a session is established…or quite many attempts :slight_smile:

When I ran in a 3rd terminal “ros2 topic list” => “ros2: command not found.”
What is the easiest way to install ROS2 Humble for this tutorial. Can it be done using docker?

Hello all,
I have a question about using micro-ROS as an intermediary between a raspberry pi and a teensy 4.1. The pi is our runtime env. and the teensy is used as a microcontroller to offset load from the pi.
Our previous system ran on ROS1, which meant this kind of connection between the two boards could be done over rosserial . However we want to upgrade to ROS2, meaning we can no longer use rosserial.
My question is, is this a good use-case for micro-ROS or would it make more sense to implement ROS2_control for this hardware configuration? What would be better in the long-term?